VRF em Switches e Roteadores Cisco

A utilização de VRF (Virtual Routing and Forwarding) em Roteadores e Switches Cisco possibilita a criação de tabelas de roteamentos virtuais que trabalham de forma independente da tabela de roteamento “normal” (geralmente chamada de tabela de roteamento global [Global Routing Table]).

Da mesma forma como a utilização de VLANs em Switches Ethernet permitem a divisão de dominios de broadcasts, a utilização de VRF permite a virtualização da tabela de roteamento.

Apesar da tecnologia VRF ter a sua função vinculada às redes MPLS (por ser largamente utilizado em Provedores e Data Centers) há a possibilidade de criar tabelas de roteamento apenas para funções locais do Roteador, chamado de VRF-lite ou também Multi-VRF.

Você pode ser perguntar: “Mas por qual razão eu precisaria configurar outra tabela de roteamento em meu roteador?

Geralmente as empresas que prestam serviços de TI, monitoração de redes e serviços, precisam lidar com clientes que usam em sua maioria endereços da RFC1918 (endereços IPv4 privados) o que aumenta a probabilidade de mais de um cliente possuir endereços de rede IPv4 iguais (além do fator de segurança ) além da complexidade em usar a segregação das redes com NAT e ACL. A utilização de VRFs possibilita a independência das tabelas de roteamento, permitindo que uma tabela de rotas não possua roteamento com as outras (por padrão).

Segue abaixo o exemplo da configuração do cenário acima:

# Criando as VRFs 

ip vrf ABC
! criando a VRF chamada “ABC”
#
ip vrf XYZ
! criando a VRF chamada “XYZ”
#


!
interface Ethernet1/0
 ip vrf forwarding ABC
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1/1
 ip vrf forwarding ABC
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet1/2
 ip vrf forwarding XYZ
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1/3
 ip vrf forwarding XYZ
 ip address 10.1.1.1 255.255.255.0
#

Validando as VRFs criadas…

Roteador#show ip vrf
  Name                             Default RD          Interfaces
  ABC                                         Et1/0
                                                       Et1/1
  XYZ                                         Et1/2
                                                       Et1/3

Verificando a tabela de roteamento global e a tabela de roteamento de cada VRF.

Roteador#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set
! Em nosso exemplo, não configuramos IP na tabela Global

R3#show ip route vrf ABC
Routing Table: ABC
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C    192.168.1.0/24 is directly connected, Ethernet1/0
C    192.168.2.0/24 is directly connected, Ethernet1/1
! Rotas da VRF ABC

R3#show ip route vrf XYZ
Routing Table: XYZ
Codes: C - connected, S - static, R - RIP, M - mobile, B – BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Ethernet1/3
C    192.168.1.0/24 is directly connected, Ethernet1/2
! Rotas da VRF XYZ

Além do Roteamento para as interfaces diretamente conectadas é possível também separar as rotas estáticas e protocolos de Roteamento em processos independente para cada VRF

! Exemplo de configuração de rota estatica por VRF
ip route vrf ABC 0.0.0.0 0.0.0.0 192.168.1.254
ip route vrf XYZ 0.0.0.0 0.0.0.0 192.168.1.100

! Criação de processos individuais do OSPF por VRF
Roteador(config)#router ospf 1 vrf?
vrf     

Dica : Configure o endereço IP à uma interface somente após atribuir a VRF, pois o Roteador irá remover a configuração IP da interface.
Roteador(config-if)#ip vrf forwarding ABC
% Interface Loopback0 IP address 172.16.1.1 removed due to enabling VRF ABC

Até … 😉

Outras referências

http://www.cocheno.com/2012/08/introducao-ao-vrf-lite/
http://labcisco.blogspot.com.br/2013/01/configuracao-da-nuvem-mpls-em-provedores.html

http://www.comutadores.com.br/vrf-em-switches-e-roteadores-hpn-vpn-instance/
http://packetlife.net/blog/2009/apr/30/intro-vrf-lite/

Leave a Reply

Your email address will not be published. Required fields are marked *